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N30 Supervisory Controller 
Quick Start

Introduction 
The purpose of this document is to help get an N30 Supervisory 
Controller (N30) system up and running quickly by providing an 
overview and reference to how some of the system’s tools work 
together. This document contains scenarios in the form of flowcharts 
and checklists, and provides references to other literature to describe: 

• concepts related to setting up an N30 Supervisory Controller 
system 

• initial setup of an N30 Supervisory Controller site 

• steps to generate a typical N30 Supervisory Controller database 

• steps to generate a database for networked N30s 
This document also contains communications scenarios and 
information for N30 tasks using Project Builder software. These 
checklists include scenarios on how to: 

• connect to an N30 using a VT100 Terminal Emulator 

• use checklists for communication scenarios 

• upload an N30 via direct serial connection 

• download an N30 via direct serial connection 

• upload an N30 via dial-up connection 

• download an N30 via dial-up connection  

• upload an N30 via Ethernet 

• download an N30 via Ethernet 
Note: This document applies to N30 and N31 Supervisory 

Controllers unless otherwise noted. 
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Key Concepts 
Using This Document 

Table 1 describes where to go in this document to accomplish specific 
tasks. 

Table 1: Using This Document 
For Information About Refer To 
Connecting to an N30 Using a 
VT100 

Connecting to an N30 Using a VT100 Terminal 
Emulator procedure in the Detailed 
Procedures section 

Getting an Overview of a Site 
Installation 

Site Installation Flowchart in this Key Concepts 
section 

Getting an Overview of 
Generating a Database 

Database Generation in this Key Concepts 
section 

Working through Checklists of 
Tasks for Uploading and 
Downloading 

Using Checklists for Communication Scenarios 
in the Detailed Procedures section 

Troubleshooting an N30 Troubleshooting section 

 

Related Information 
Refer to Table 2 to find related information in other documents. 

Table 2: Related Information 
For Information About Refer To 
Installing an N30 N30 Supervisory Controller Installation 

Technical Bulletin (LIT-6891100) 
Networking an N30 N30 Supervisory Controller Networking 

Technical Bulletin (LIT-6891300) 
Using Bootstrap Protocol 
(BOOTP) and Domain Name 
System (DNS) Protocol in an 
N30 Network 

N30 Supervisory Controller Networking 
Technical Bulletin (LIT-6891300) 

Working with Objects Using 
the VT100 

N30 Supervisory Controller User’s Manual 

Working with Objects Using 
Project Builder 

Project Builder User’s Guide 

Setting up Direct Serial or 
Dial-up Connections from a 
Personal Computer (PC) to an 
N30 

Direct Connect and Dial-up Connection on 
Windows 2000 and Windows XP Operating 
Systems Application Note (LIT-6893450) 

Using Site Book Site Book User’s Guide 
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Definition of Terms 

N30 Database 
Database where the N30 system is defined. Contains information about 
controllers, points, alarms, and other N30 objects. 

N30 Device Object 
The N30 Device object defines the attributes that represent the 
externally visible characteristics of an N30. 

Site Manager 
The N30 within a site that contains the Site object. The Site object is 
responsible for the synchronization of global objects, time 
synchronization, and device status monitoring within the site. There 
can be only one Site Manager per site. 

Copy Holder 
The device is designated to hold a copy of objects for a site. It is a 
backup for the Site Manager and takes over the Site Manager duties if 
the primary Site Manager device fails. 

Site Object 
The Site object maintains a list of devices on the site including 
supervisory controllers and workstations. The primary Site object for a 
site is located on the Site Manager device. A copy of it is located on 
the copy holder device. 

Site Data Object (in the N30) 
Holds information or data relating to the entire site, such as the site 
name. Acts as a repository for global data for the local device. 

Flash Memory 
A type of nonvolatile memory within the N30 device. The N30 stores 
configuration data, startup code, boot code, main code, and the archive 
database within this memory. 

Firmware 
The N30 program in flash memory is called firmware. The firmware 
can be updated through the Project Builder tool. When the Project 
Builder tool is purchased or upgraded, it contains the latest firmware 
version level of the N30. 
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Passwords 
When working with N30 systems, there are several password-related 
items that you must understand. 

• Administrator Password: The administrator of a site is the only 
user with the ability to create, modify, or delete operator objects. 
With the exception that the administrator cannot change an 
Operator password after its initial creation, the administrator has 
unrestricted access to and control over all other objects defined for 
the site. See the Working with Operator Objects (LIT-6892050) 
chapter of the N30 Supervisory Controller User’s Manual for more 
details. 

 The administrator’s login ID is ADMIN and the default password 
is 2468. 

• Operator Password: The Operator Password is an attribute of the 
Operator object. The Minimum Password Length is an attribute of 
the Site Data object. The Operator Password is the password that 
an individual would use to log on to an N30. The access level of 
the user is controlled when the operator object is set up. There are 
seven defined access levels. See the Working with Operator 
Objects (LIT-6892050) chapter of the N30 Supervisory Controller 
User’s Manual for more details. 

• Point-to-Point Protocol (PPP) Password: This is the password 
used when establishing a Point-to-Point Protocol (PPP) connection 
to an N30 site or M3 Workstation. The PPP Password in Site Book 
must match the PPP Password in the N30 device object for the site 
you want to connect. Changing the PPP Password requires 
changing it in both Project Builder and the Site Book. 

 The default PPP login ID is jci and the default password is 2468. 

Media Access Control (MAC) Address 
Media Access Control Address. A hardware address of a device 
connected to a network, expressed as a 48-bit hexadecimal number. 
The MAC address uniquely identifies each node on a network. 
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Internet Protocol (IP) 
The N30 supports several IP protocols including BOOTP, DNS, and 
Simple Mail Transfer Protocol (SMTP). These protocols can be used 
independently of one another. For example, a site may include a 
BOOTP server, but not a DNS server. 
Notes: Check with your system administrator to verify whether the 

network uses these protocols. 
Although BOOTP and DNS are supported with Release 5.0, 
their use is not required. Static IP addressing is still a viable 
option. 

BOOTP 
BOOTP allows a device (such as an N30) to obtain and configure its 
own IP information. The device sends a request to the BOOTP server 
and the BOOTP server responds by providing the device its 
IP information, such as its IP address and, if a DNS server is used also, 
its host name. For N30 networking, configure the BOOTP server to 
assign static IP addresses to devices. 
A BOOTP server is not required in order to provide BOOTP protocol, 
however. Most Dynamic Host Configuration Protocol (DHCP) servers 
can be configured to accept and respond to BOOTP requests. To 
assign IP addresses using BOOTP protocol, configure the DHCP 
server to accept BOOTP requests. This allows a DHCP server to 
dynamically assign a specific IP address to a device based on its MAC 
address. 
Note: In this document, the term “BOOTP server” refers both to 

BOOTP servers and to DHCP servers configured to accept 
BOOTP requests. 

By setting the BOOTP Enabled attribute of an N30 to True, you allow 
the N30 to obtain and configure its IP address, IP mask, IP router 
address, host name, domain name, and DNS server IP address. See the 
N30 Supervisory Controller Networking Technical Bulletin 
(LIT-6891300). Also, see the N30 Device (LIT-694610) chapter in the 
Object Dictionary. 
Note: When a network includes both BOOTP and DNS servers, 

make certain that host names and IP addresses provided by 
the BOOTP server are consistent with those configured in 
the DNS server. 
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DNS 
DNS allows the conversion of text-based names (such as a Web site 
address) into numeric IP addresses. With a DNS server, you can assign 
a host name (such as N30-Floor3) to an IP address (such as 
172.16.68.243). An N30 uses the Object Name of the device object as 
its host name. A host name can be reassigned to different IP addresses 
as needed. 
Note: When a network includes both BOOTP and DNS servers, 

make certain that host names and IP addresses provided by 
the BOOTP server are consistent with those configured in 
the DNS server. 

A DNS server simplifies the work of identifying individual devices on 
a network. For example, when setting up Broadcast Management 
objects, you can elect to identify an object by its host name rather than 
entering its IP address. See the N30 Supervisory Controller 
Networking Technical Bulletin (LIT-6891300). 

SMTP 
SMTP is the standard protocol for sending e-mail messages over an 
Ethernet connection between servers. The E-mail object uses SMTP to 
send e-mail notifications of alarms. See the E-mail (LIT-1201115) 
chapter in the Object Dictionary. 

Broadcast Management (BM) Object 
The Broadcast Management object (previously called BACnet® 
Broadcast Management Device [BBMD] object) maintains a list of 
designated devices on other Ethernet IP network segments. The device 
needs this information to determine where to forward N30 broadcast 
messages. 
Note: In a standard configuration, only one Broadcast Management 

object is defined for each network segment. 

The data in each Broadcast Management object must be the same in all 
devices that have an enabled Broadcast Management object. 
See the N30 Supervisory Controller Networking Technical Bulletin 
(LIT-6891300) for further details. 

Packet Internet Groper (PING) 
A utility to determine whether a specific IP address is accessible. 
It works by sending a packet to the specified address and waiting for a 
reply. The PING utility is available whenever Windows Transmission 
Control Protocol/Internal Protocol (TCP/IP) protocol is installed on a 
computer. 
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Site Book 
Program used to define and edit the set of physical or logical locations 
that can be connected in an N30/M3 Workstation network. Each site 
within the database has parameters needed to establish the connection. 
The Site Book configures sites for N30 devices. See the Site Book 
User’s Guide for details. 

Non-Segmented N30 Network 
A non-segmented N30 network consists of either a standalone N30 or 
multiple N30s on a single network segment. These N30s are not 
separated by routers and do not require the use of a Broadcast 
Management object. 

Segmented N30 Network 
A segmented N30 network consists of N30s on different network 
segments separated by routers. In this kind of network, one N30 on 
each network segment must have a Broadcast Management object in 
order for communications across the segments to take place. 

Site Installation Flowchart 
This flowchart (shown in four parts - Figure 1, Figure 2, Figure 3, and 
Figure 4) provides a high level view of the steps you use to set up an 
N30 site over Ethernet. The following materials are recommended to 
perform the actions in this flowchart: 

• laptop PC with Project Builder and a VT100 Terminal Emulator 
installed 

• NULL modem serial cable to connect to the VT100 object in the 
N30 

• crossover Ethernet cable 

• straight-through Ethernet cables 

• Ethernet hub (optional) 
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Do all N30s have
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Network Administrator

to provide BOOTP
configuration
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(CAT5).

Verify with System or
Network Administrator
that the BOOTP server

is configured.

B

No

No

BOOTP.vsd

BOOTP

 
1. Although BOOTP is supported with Release 5.0, it is not required. Static 

IP addressing is still a viable option. 
To use BOOTP, the network must contain a BOOTP server that can be 
configured to assign IP addresses to N30s. See the N30 Supervisory Controller 
Networking Technical Bulletin (LIT-6891300) for details. 

2. See Connecting to an N30 Using a VT100 Terminal Emulator in this document. 
 If the N30s have a BOOTP Enabled attribute, the firmware supports BOOTP. If 

the N30s have a DHCP Enabled attribute instead of a BOOTP Enabled attribute, 
the firmware does not support BOOTP (it is Release 2.2 or earlier). You must 
download the updated firmware (Release 5.0 or later) to the N30s before using a 
BOOTP server to assign IP addresses. 

3. You must provide information, including MAC addresses of the N30s and the 
desired host names for N30s (if a DNS server is used). The N30 Supervisory 
Controller Networking Technical Bulletin (LIT-6891300) provides an appendix 
with information to provide to the System or Network Administrator. 

Figure 1: Site Installation Flowchart - Part 1 
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crossover Ethernet cable
or direct connect to Port 3
using null modem cable.

Choose the IP
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they are on the

same network. (5)

Connect to each N30
using a VT100 and
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Fill in the Networking
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Hardware (N30s)

physical n30.vsd

A

B

Are you adding
the N30 to an existing

network?
No Yes

No

 
4. See Connecting to an N30 Using a VT100 Terminal Emulator in this document. 
 The Networking Worksheets are found in the N30 Supervisory Controller 

Networking Technical Bulletin (LIT-6891300). 
5. If you are not using BOOTP, obtain unique IP address, IP mask, and IP router 

address from the Network Administrator. If there is no network at the installation 
site or if or if you must download updated firmware before using BOOTP, leave 
the N30 addresses at their factory-preset value. If using arbitrary IP addresses 
for the N30s, conflicts may occur if they are ever connected to other networks; in 
that case, the IP addresses have to be reassigned prior to linking the networks 
together. 

Figure 2: Site Installation Flowchart - Part 2 
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6. If you are not using BOOTP, or if you must download updated firmware before 

using BOOTP, set the address of the N30 determined in the previous step. If 
working in a local testing configuration (not at the site), remember to change the 
database after the N30 is installed at the site. 

 See the flowcharts in the Database Generation section in this document and the 
Project Builder User’s Guide for more details on creating a new database. 

Figure 3: Site Installation Flowchart - Part 3 
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7. There are several communications scenarios: Ethernet (shown), direct serial 

connection, and dial-up (modem). These are further differentiated by the PC’s 
operating system. See the Site Book User’s Guide for details on establishing 
communications with the N30 or M3 Workstation sites. 

Figure 4: Site Installation Flowchart - Part 4 
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Database Generation 
This section provides some sample scenarios for creating or editing 
databases for N30s. The purpose of this section is to provide an 
overview of real world operation to assist in setting up your own 
project databases. 

Example Database 
An example N30 database is supplied with M-Tool as a guide to 
creating objects for your N30 database. The N30 example database 
provides examples of how object attributes must be configured for 
objects such as the Local Display Terminal (LDT), Multiple Command 
Object (MCO), and Interlock objects. Use this database as a basis of 
design for any new project designed with Project Builder. The 
N30 example database.mpb file is located in the C:\ Documents and 
Settings \ All Users \ Application Data \ Johnson Controls \ M-Data \ 
Database \ N30 example database directory. 
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Typical Database Generation for a Non-Segmented N30 
Network 
Figure 5 shows the steps typically used for a non-segmented 
N30 network database generation. 

Start Project Builder. See the
Project Builder User's Guide.

Create a new project.
See the Project Builder

User's Guide.

Define the N30
containers desired for

the project. See Getting
Started in the Project
Builder User's Guide.

Create the site object.
See Defining a Site in

the Project Builder
User's Guide.

Import PRN, DMO, or
HMC files, or AIM

schedules. See the
Project Builder User's

Guide.

Delete unneeded points
and edit imported files
as necessary. See the
Project Builder User's

Guide.

Mass copy controllers
as required. See the

Project Builder User's
Guide.

Add additional objects
such as Schedules,
DLLR, OST, Global
Data Sharing, etc.

See the N30
Supervisory Controller
User's Manual and the

Object Dictionary.

Create groups to further
organize data as

desired. See the N30
Supervisory Controller
User's Manual and the

Object Dictionary.

Save the database.
See the Project Builder

User's Guide.

Add N30s to the project
database. See Getting
Started in the Project
Builder User's Guide.

NoSgdbgen.vsd

If there are multiple
N30s on the segment,
define a copy holder
N30. See Defining a
Site in the Project

Builder User's Guide.

Download to the N30.
See the Project Builder

User's Guide.*

 
* See the Detailed Procedures section in this document for several downloading 

scenarios. 

Figure 5: Typical Database Generation for a 
Non-Segmented N30 Network 
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Database Generation for a Segmented N30 Network 
Figure 6 shows the general procedures necessary for setting up a 
segmented N30 network. Note that it is similar to the procedures used 
to set up a standalone N30. The main difference is the need to define a 
Broadcast Management (formerly BBMD) object. 

Start Project Builder.
See the Project Builder

User's Guide.

Create a new project. See
the Project Builder User's

Guide.

Define the N30 containers
desired for the project. See

Getting Started in the Project
Builder User's Guide.

Create the site object.
See Defining a Site in the

Project Builder User's
Guide.

Import PRN, DMO, or HMC
files, or AIM Schedules. See

the Project Builder User's
Guide.

Delete unneeded points and
edit imported files as

necessary. See the Project
Builder User's Guide.

Mass copy controllers as
required. See the Project

Builder User's Guide.

Create groups to further organize
data as desired. See the N30
Supervisory Controller User's

Manual and the Object Dictionary.

Save the database.
See the Project Builder User's

Guide.

Download to the N30. See the
Project Builder User's Guide.**

Add N30s to the project
database. See Getting

Started in the Project Builder
User's Guide.

Segn30dbgen.vsd

Add additional objects such
as Schedules, DLLR, OST,
Global Data Sharing, etc.
See the N30 Supervisory
Controller User's Manual

and the Object Dictionary.

Add a Broadcast Management
object to one N30 on each

segment that needs to
communicate with each other.

See the N30 Supervisory
Controller Networking Technical

Bulletin (LIT-6891300).*

Define the copy holder N30.
See Defining a Site in the

Project Builder User's
Guide.

 
* In a standard configuration, only one Broadcast Management object is defined for each network segment. 

If the site has a DNS server, you can identify Broadcast Management objects by their host names rather 
than their IP addresses. See the N30 Supervisory Controller Networking Technical Bulletin (LIT-6931300) 
for more information. 

** See the Detailed Procedures section in this document for several downloading scenarios. 

Figure 6: Segmented N30 Network Database Generation 
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Checklists for Communication Scenarios 
The Detailed Procedures section provides examples of 
communications scenarios and the steps typically required to perform 
them successfully. References to more detailed information are 
included where appropriate. Each scenario is independent and 
demonstrates the steps required to set up each task using Project 
Builder software. Detailed procedures for each step, including screen 
captures, are contained in the documents referred to in the steps. The 
main steps can be used as a checklist to track your progress while 
setting up a system. The substeps may vary slightly from job to job. 
If you experience problems with these steps, please consult the 
Troubleshooting section of this document. 
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Detailed Procedures 
Connecting to an N30 Using a VT100 Terminal Emulator 

To connect to an N30 using a VT100 Terminal Emulator: 
1. Connect a null modem cable to the N30. 
2. Log in to the N30 using a VT100 Terminal Emulator on your PC. 

Enter the Login ID of ADMIN and Password of 2468. 
3. Press F3 to Edit the N30. 

Uploading an N30 via Direct Serial Connection 
Uploading an N30 database through a direct serial connection is a 
multistep process. Table 3 provides a checklist to verify all steps are 
completed and provides references to further information about the 
processes. 

Table 3: Uploading N30s via Direct Serial Connection Checklist 
Step Task Done

Create a new project in Project Builder.  1 
On the File menu, select New. Enter a name for the project. 
Note: The name of the project only applies to Project Builder and is not loaded into 

the N30. 
For further information, see the Project Builder User’s Guide. 

 

Add an N30 default object to the project database.  2 
• From the Devices and Collections folder in the Object Library, drag the N30 default 

collection to your database. 
• Change the default name of the N30 in your database to match the name of the N30 

that you are going to upload or download. 
Notes: If you do not know the name of the N30, attempt a download using the name in 

your database. When Site Manager starts, it shows the name of the 
connected N30. Change the name of the N30 in your project database to match 
the name shown in Site Manager. 
Alternately, use a VT100 or VT100 Emulator to connect to the N30 and identify 
its name. See Connecting to an N30 Using a VT100 Terminal Emulator in this 
section. 

 

Define a network connection icon for a direct serial connection.  3 
Refer to the Direct Connect and Dial-up Connection on Windows 2000 and Windows XP 
Operating Systems Application Note (LIT-6893450) for details.  

Define a direct serial connection site in the Site Book.  4 
See Configuring a Site in the Defining a Site chapter of the Project Builder User’s Guide.  

Continued on next page . . . 
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Step 
(Cont.) 

Task Done

Add the site to the project database.  5 
• Select the Site Name from the drop-down list on Project Builder’s Edit Site screen. 
Note: If the Edit Site screen is not open from Step 4, click Edit Site on the Edit menu. 
• Define the Site Manager device by selecting the N30 from the drop-down list. 
• Define the Minimum Password length. 
Note: The Site Manager and Minimum Password length are required fields. The Copy 

Holder device and Site Group object fields are optional. 
• Click OK. 
For further information, see the Project Builder User’s Guide. 

 

Upload the N30.  6 
• Connect a Null Modem cable between the PC and an N30 port. 
• Select the N30 device in Project Builder by clicking on the row number to highlight it. 
• Right-click and select Upload Objects from the menu that appears. 
• Click Yes to proceed. 
• Look at the Loader window at the bottom of the screen for the upload status. 
See the Uploading and Downloading (LIT-693250) chapter in the Project Builder User’s 
Guide for more details. 
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Downloading an N30 via Direct Serial Connection 
Downloading an N30 database through a direct serial connection is a 
multistep process. Table 4 provides a checklist to verify that all steps 
are completed and provides references to further information about the 
processes. 

Table 4: Downloading N30s via Direct Serial Connection Checklist 
Step Task Done

Create a new project in Project Builder.  1 
On the File menu, select New. Enter a name for the project. 
Note: The name of the project only applies to Project Builder and is not loaded into 

the N30. 
For further information, see the Project Builder User’s Guide. 

 

Add an N30 default object to the project database.  2 
• From the Devices and Collections folder in the Object Library, drag the N30 default 

collection to your database. 
• Change the name of the N30 in your database to match the name of the N30 that you 

are going to download. 
Notes: If you do not know the name of the N30, attempt a download using the name in 

your database. When Site Manager starts, it shows the name of the connected 
N30. Change the name of the N30 in your project database to match the name 
shown in Site Manager. 
Alternately, use a VT100 or VT100 Emulator to connect to the N30 and identify 
its name. See Connecting to an N30 Using a VT100 Terminal Emulator in this 
section. 

 

Define a network connection icon for a direct serial connection.  3 
Refer to the Direct Connect and Dial-up Connection on Windows 2000 and Windows XP 
Operating Systems Application Note (LIT-6893450) for details.  

Define a direct serial connection site in the Site Book.  4 
See Configuring a Site in the Defining a Site Chapter of the Project Builder User’s Guide.  
Add the site to the Project database.  5 
• Select the Site Name from the drop-down list on Project Builder’s Edit Site screen. 
Note: If the Edit Site screen is not open from Step 4, click Edit Site on the Edit menu. 
• Define the Site Manager device by selecting the N30 from the drop-down list. 
• Define the Minimum Password Length. 
Note: The Site Manager and Minimum Password length are required fields. The Copy 

Holder device and Site Group object fields are optional. 
• Click OK. 
For further information, see the Project Builder User’s Guide. 

 

Continued on next page . . . 
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Step 
(Cont.) 

Task Done

As an optional step, a database can be defined at this point. This is not required for a 
download to be successful. 

 6 

• Select the N30 device by clicking on the row number. 
• See the Database Generation section of this document for flowcharts on creating 

databases. 
Note: If importing a .prn file, the .prn file must be Short form. Check by opening the file 

with Notepad. 

 

Download the N30.  7 
• Connect a Null Modem cable between the PC and an N30 port. 
• Select the N30 device in Project Builder by clicking on the row number to highlight it. 
• Right-click and select Download Objects from the menu that appears. 
• Click Yes to proceed. 
• Look at the Loader window at the bottom of the screen for the download status. 
See the Uploading and Downloading (LIT-693250) chapter in the Project Builder User’s 
Guide for more details. 
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Uploading an N30 via Dial-Up Connection 
Uploading an N30 database through a dial-up connection is a multistep 
process. Table 5 provides a checklist to verify that all steps are 
completed and provides references to further information about the 
processes. 

Table 5: Uploading an N30 via a Dial-Up Connection 
Step Task Done

Create a new project in Project Builder.  1 
• On the File menu, select New. Enter a name for the project. 
Note: This name only applies to Project Builder and is not loaded in the N30. 
• All other fields are optional. 
For further information, see the Project Builder User’s Guide. 

 

Add an N30 to the project.  2 
• Drag the N30 Default object into the project. 
• Change the name of the N30 in Project Builder to match the name in the N30. 
Notes: If you do not know the name of the N30, attempt a download using the name in 

your database. When Site Manager starts, it shows the name of the 
connected N30. Change the name of the N30 in your project database to match 
the name shown in Site Manager. 
Alternately, use a VT100 or VT100 Emulator to connect to the N30 and identify 
its name. See Connecting to an N30 Using a VT100 Terminal Emulator in this 
section. 

 

Define a network connection icon for each site with which you want a dial-up connection.  3 
Refer to the Direct Connect and Dial-up Connection on Windows 2000 and Windows XP 
Operating Systems Application Note (LIT-6893450) for further information. 

 

Define a Modem (Dial-Up) site in the Site Book.  4 
• Open the Site Book by selecting Edit > Edit Site in Project Builder and click on 

Directory. 
• Click Add, Select Modem (Dial-Up), and click OK. 
• Enter the Site Name. 
Note: The Site Name is downloaded into the N30. 
• Define the Windows Phonebook Entry by selecting the name of the Network 

connection icon from the drop-down list. 
• Enter the PPP Login ID and Password. 
Note: The default PPP Login ID and Password are jci and 2468. 
• Leave the Network Number at the default value of 100. 
• Click OK. 
• Click Close to close the Site Book and return to the Edit Site window. 

 

Continued on next page . . .  
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Step 
(Cont.) 

Task Done

Add the Site to the project.  5 
• Select the site name from the drop-down list on Project Builder’s Edit Site screen. 
Note: If the Edit Site screen is not open from Step 4, click Edit Site on the Edit menu. 
• Define the Site Manager device by selecting the N30 from the drop-down list. 
Note: The Site Manager is a required field. However, the Copy Holder and the Site 

Group object fields are optional. 
• Define the Minimum Password length between a value of 1-8. 
• Click OK. 
For further information, see the Project Builder User’s Guide. 

 

Upload the N30.  6 
• Connect a modem to the PC with a 9-25 pin modem cable. 
• Select the N30 device by clicking on the row number to highlight it. 
• Right-click and select Upload Objects from the menu. 
• Click Yes to proceed. 
• Look at the Loader window at the bottom of the screen for the upload status. 
See the Uploading and Downloading (LIT-693250) chapter in the Project Builder User’s 
Guide. 
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Downloading an N30 via Dial-Up Connection 
Downloading an N30 database through a dial-up connection is a 
multistep process. Table 6 provides a checklist to verify that all steps 
are completed and provides references to relevant information. 

Table 6: Downloading an N30 via Dial-Up Connection 
Step Task Done

Create a new project in Project Builder.  1 
• On the File menu, select New. Enter a name for the project. 
Note: This name only applies to Project Builder and is not loaded in the N30. 
• All other fields are optional. 

 

Add an N30 to a project.  2 
• Drag the N30 Default object into the project. 
• Change the name of the N30 in Project Builder to match the name in the N30. 

 

Define a network connection icon for each site with which you want a dial-up connection.  3 
Refer to the Direct Connect and Dial-up Connection on Windows 2000 and Windows XP 
Operating Systems Application Note (LIT-6893450) for further information. 

 

Define a Modem (Dial-Up) Site in the Site Book.  4 

• Open the Site Book by selecting Edit > Edit Site in Project Builder, and then click on 
Directory. 

• Click Add, Select Modem (Dial-Up), and click OK. 
• Enter the Site Name. 
Note: The Site Name is downloaded into the N30. 
• Define the Windows Phonebook Entry by selecting the name of the Network 

connection icon from the drop-down list. 
• Enter a Login ID of jci and a Password of 2468. 
Note: This is the PPP Password and not the Operator Password. The default Operator 

Password, ADMIN, does not work for a Login ID. 
• Leave the Network Number at the default value of 100. 
• Click OK. 
• Click Close to close the Site Book and return to the Edit Site window. 

 

Add the Site to the project.  5 
• Select the Site Name from the drop-down list. 
Note: Select Edit > Edit Site in Project Builder to open the Edit Site window if not open 

from Step 4. 
• Define the Site Manager device by selecting the N30 from the drop-down list. 
Note: The Site Manager is a required field. However, the Copy Holder and the Site 

Group object fields are optional. 
• Define the Minimum Password length between a value of 1-8. 
• Click OK. 

 

Continued on next page . . .  
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Step 
(Cont.) 

Task Done

As an optional step, a database can be defined at this point. This is not required for a 
download to be successful. 

 6 

• Select the N30 device by clicking on the row number. 
• See the Database Generation section of this document for flowcharts. 
Note: If importing a .prn file, the .prn file must be Short form. Check by opening the file 

with Notepad. 

 

Download the N30.  7 
• Connect a modem to the PC with a 9-25 pin modem cable. 
• Select the N30 device by clicking on the row number to highlight it. 
• Right-click and select Download Objects from the menu. 
• Click Yes to proceed. 
• Look at the Loader window at the bottom of the screen for the download status. 

Consult the Troubleshooting section of this document or Project Builder’s online help 
for any errors that you experience. 
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Uploading an N30 via Ethernet 
Uploading an N30 database through an Ethernet connection is a 
multistep process. Table 7 provides a checklist to verify that all steps 
are completed and provides references to further information. 

Table 7: Uploading an N30 via Ethernet 
Step Task Done

Create a new project in Project Builder.  1 
• On the File menu, select New. Enter a name for the project. 
Note: This name only applies to Project Builder and is not loaded in the N30. 
• All other fields are optional. 

 

Add an N30 to a project.  2 
• Drag the N30 Default object into the project. 
• Change the name of the N30 in Project Builder to match the name in the N30. 

 

Define an Ethernet Site.  3 
• Open the Site Book by selecting Edit > Edit Site in Project Builder and then click on 

Directory. 
• Click Add and Select Ethernet LAN. 
• Enter the Site Name. 
Note: The Site Name is downloaded into the N30. 
• Leave the Network Number at the default value of 1001. 
Note: The Network Number must be unique from other Ethernet Sites. 
• The default BACnet IP Port value is 47808. 
Note: 47808 is the decimal equivalent of BAC0 in hexadecimal. This value does not 

need to be changed unless multiple sites are on the same Ethernet network. If 
you change the value, be certain to document the new value. 

• Click OK. 
• Click Close to close the Site Book and return to the Edit Site window. 

 

Change the Site for the project.  4 
• Select Edit > Edit Site in Project Builder to open the Edit Site window if not still open 

from previous step. 
• Select the Ethernet Site Name from the drop-down list. 
• Verify the Site Manager device matches the N30 name listed in the project. 
Note: The Site Manager is a required field. However, the Copy Holder and the Site 

Group object fields are optional. 
• Define the Minimum Password length between a value of 1-8. 
• Click OK. 

 

Continued on next page . . .  
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Step 
(Cont.) 

Task Done

Determine the IP address of the N30 using a VT100 Terminal Emulator on your PC. 
The default IP address of the N30 is based on the N30’s factory-set MAC address. 

 5 

• Connect a Null Modem cable to the N30. 
• Log in to the N30 using a VT100 Terminal Emulator on your PC, and enter the Login 

ID of ADMIN and a Password of 2468. 
• Highlight the N30 name and press Enter. 
• Press F3 to Edit the N30. 
• Press the down arrow and then tab to the IP address. 
• Press Enter and write down the IP address. 
• Repeat the steps for the IP mask and IP router address. 

 

Set the IP address of the N30 in Project Builder.  6 
• Double-click on the N30 Device Object to open the object and view the 

communication info. 
Note: If the site uses a BOOTP server, click the BOOTP Enabled drop-down list and 

click True. Because the BOOTP server allows the N30 to obtain its own 
IP address, you can skip the three steps below that explicitly set the IP address 
information and proceed to Step 7. 

• Click on the Array Elements button next to the IP Address and type in the IP address. 
• Click on the Array Elements button next to the IP Mask and type in the IP mask. 
• Click on the Array Elements button next to the IP Router Address and type in the 

IP router address. 

 

Set the IP address of the PC.  7 
• Right-click on the Network Neighborhood and select Properties. 
• Select the TCP/IP Protocol that has the Ethernet card bound to it and click on 

Properties. 
• Select the IP Address tab and choose Specify an IP address. 
• Type in an IP address that matches that of the N30 except for the last octet. 
• Type in the Subnet Mask that matches that of the N30. 
• Click OK and restart the PC. 
• Check the current IP address of the PC. Use the following method: 

On the Windows Start menu, click Programs > Accessories > Command Prompt. 
Type IPConfig. Press the Enter key. Note the IP address. 

• Make sure the N30 is accessible by typing PING xxx.xxx.xxx.xxx from an MS-DOS 
prompt with the IP address of the N30. 

Note: The xxx.xxx.xxx.xxx represents the IP address of the N30. 

 

Upload the N30 using Ethernet.  8 
• Connect the Ethernet cables between the PC and the N30. 
• Select the N30 device by clicking on the row number to highlight it. 
• Right-click and select upload objects. 
• Click Yes to proceed. 
• Look at the Loader window at the bottom of the screen for the upload status. Consult 

the Troubleshooting section of this document or Project Builder’s online help for any 
errors that you experience. 

 

Downloading an N30 via Ethernet 
Downloading an N30 database through an Ethernet connection is a 
multistep process. The following table provides a checklist to verify 



 N30 Supervisory Controller Quick Start Technical Bulletin 27

that all steps are completed and provides references to further 
information about the processes. 

Table 8: Downloading an N30 via Ethernet 
Step Task Done

Create a new project.  1 
• Select File > New and enter the name of the project. 
Note: This name only applies to Project Builder and is not loaded in the N30. 
• All other fields are optional. 

 

Add an N30 to a project.  2 
• Drag the N30 Default object into the project. 
• Change the name of the N30 in Project Builder to match the name in the N30. 
Notes: If you do not know the name of the N30, attempt a download using the name in 

your database. When Site Manager starts, it shows the name of the 
connected N30. Change the name of the N30 in your project database to match 
the name shown in Site Manager. 
Alternately, use a VT100 or VT100 Emulator to connect to the N30 and identify 
its name. See Connecting to an N30 Using a VT100 Terminal Emulator in this 
section. 

 

Define an Ethernet Site.  3 
• Open the Site Book by selecting Edit > Edit Site in Project Builder and then click on 

Directory. 
• Click Add and Select Ethernet LAN. 
• Enter the Site Name. 
Note: The Site Name is downloaded into the N30. 
• Leave the Network Number at the default value of 1001. 
Note: The Network Number must be unique from other Ethernet Sites. 
• The default BACnet IP Port value is 47808. 
Note: 47808 is the decimal equivalent of BAC0 in hexadecimal. This value does not 

need to be changed unless multiple sites are on the same Ethernet network. 
If you change the value, be certain to document the new value. 

• Click OK. 
• Click Close to close the Site Book and return to the Edit Site window. 

 

Change the Site for the project.  4 
• Select the Site Name from the drop-down list. 
Note: Select Edit > Edit Site in Project Builder to open the Edit Site window if not open 

from Step 3. 
• Verify the Site Manager device matches the N30 name listed in the project. 
Note: The Site Manager is a required field. However, the Copy Holder and the Site 

Group object fields are optional. 
• Define the Minimum Password length between a value of 1-8. 
• Click OK. 

 

Continued on next page . . .  
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Step 
(Cont.) 

Task Done

Determine the IP address of the N30 using a VT100 Terminal Emulator on your PC.  5 
• Connect a Null Modem cable to port 1 of the N30. 
• Log in to the N30 using a VT100 Terminal Emulator on your PC. 
Note: The default Login ID is ADMIN and the Password is 2468. The default baud rate 

for N30 Ports 1 and 2 is 9600 baud; the default baud rate for Port 3 is 
57,600 baud. 

• Highlight the N30 name and press Enter. 
• Press F3 to Edit the N30. 
• Press the down arrow and then tab over to the IP address. 
• Press Enter and write down the IP address. 
• Press F4 to back up. 
• Repeat the steps for the IP mask and IP router address. 

 

Set the IP address of the N30 in Project Builder.  6 
• Double-click on the N30 Device Object to open the object and view the 

communication information. 
Note: If the site uses a BOOTP server, click the BOOTP Enabled drop-down list and 

click True. Because the BOOTP server allows the N30 to obtain its own 
IP address, you can skip the following three steps that explicitly set the 
IP address information and proceed to Step 7. 

• Click on the Array Elements button next to the IP Address and type in the IP address. 
• Click on the Array Elements button next to the IP Mask and type in the IP mask. 
• Click on the Array Elements button next to the IP Router Address and type in the 

IP router address. 

 

Set the IP address of the PC.  7 
• Right-click on the Network Neighborhood and select Properties. 
• Select the TCP/IP Protocol that has the Ethernet card bound to it, and click on 

Properties. 
• Select the IP Address tab and choose Specify an IP address. 
• Type in an IP address that matches that of the N30 except for the last octet. 
• Type in the Subnet Mask that matches that of the N30. 
• Click OK and restart the PC. 
• Check the current IP address of the PC. Use the following method: 

On the Windows Start menu, click Programs > Accessories > Command Prompt. 
Type IPConfig. Press the Enter key. Note the IP address. 

• Make sure the N30 is accessible by typing PING xxx.xxx.xxx.xxx from an MS-DOS 
prompt with the IP address of the N30. 

Note: The xxx.xxx.xxx.xxx represents the IP address of the N30. 

 

Continued on next page . . .  
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Step 
(Cont.) 

Task Done

As an optional step, a database can be defined at this point. This is not required for a 
download to be successful. 

 8 

• Select the N30 device by clicking on the row number. 
• See the Database Generation section of this document for flowcharts describing the 

steps required to generate databases. 
Note: If importing a .prn file, the .prn file must be short form. Check by opening the file 

with Notepad. 

 

Download the N30 using Ethernet.  9 
• Connect the Ethernet cables between the PC and the N30. 
• Select the N30 device by clicking on the row number to highlight it. 
• Right-click and select Download Objects from the menu that appears. 
• Click Yes to proceed. 
• Look at the Loader window at the bottom of the screen for the download status. 

Consult the Troubleshooting section of this document or Project Builder’s online help 
for any errors that you experience. 
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Troubleshooting 
Table 9: Troubleshooting a Single N30 System 
Error/Condition Problem Solutions 
Unable to upload from or 
download to an N30 

N30 name in the project database 
does not match the name of the 
N30 with which you are trying to 
communicate. 

If you do not know the name of the 
N30, attempt a download using the 
name in your database. When Site 
Manager starts, it shows the name 
of the connected N30. Change the 
name of the N30 in your project 
database to match the name 
shown in Site Manager. 
Alternately, use a VT100 or VT100 
Emulator to connect to the N30 
and identify its name. See 
Connecting to an N30 Using a 
VT100 Terminal Emulator in the 
Detailed Procedures section. 
Also refer to the Direct Connect 
and Dial-up Connection on 
Windows 2000 and Windows XP 
Operating Systems Application 
Note (LIT-6893450). These 
application notes contain further 
information about establishing 
communications with N30s. 

Unable to save project 
database 

Invalid objects are in database. See the status window in Project 
Builder for a list/description of 
errors. 

Unable to upload from or 
download to an N30 

Site not defined in Site Book. Define the site in Site Book. See 
the Site Book User’s Guide. 

When creating a new project, 
the directory field is grayed out 
so you cannot change the 
location of the new project. 

Integrate with AIM tools is checked 
in the System Tools Settings 
application. 

If you are integrating with AIM 
tools, this is normal. The AIM tools 
determine the location of the 
database. Otherwise, launch 
System Tools Settings and 
uncheck Integrate with AIM tools. 

Project Builder prompts for a 
User Name and Password and 
then fails the download. 

The Site Book login ID, which 
refers to the PPP Password and ID 
in the N30, is incorrect. Typically, it 
is incorrectly set to the default 
login ID for accessing the N30, 
ADMIN. 

The default PPP login ID for the 
N30 is jci. The Site Book login ID 
must match the PPP login ID so 
that Site Book can communicate 
with the N30. The default 
password in both cases is 2468. 

Continued on next page . . .    
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Error/Condition (Cont.) Problem Solutions 
When attempting to add a site 
to Site Book, you receive an 
Unable to read RAS 
entries error. 

Dial-up Networking is not installed 
on the computer. 

Install Dial-up Networking. Refer to 
the Direct Connect and Dial-up 
Connection on Windows 2000 and 
Windows XP Operating Systems 
Application Note (LIT-6893450). 

When attempting to upload or 
download an N30 with Project 
Builder, you receive an RAS 
630 error code. 

The port was disconnected due to 
hardware failure. This occurs when 
another application (for example, a 
VT100 Terminal Emulator) is open 
and accessing the port. 

Close your VT100 Terminal 
Emulator, or any other program 
that is using the com port you want 
to use, before uploading or 
downloading with Project Builder. 

When attempting to upload or 
download an N30 with Project 
Builder, you receive an RAS 
650 error code on a PC running 
Windows 98 software or an 
RAS 651 error code on a PC 
running Windows NT software. 

With a direct serial connection, the 
baud rate of the network 
connection icon does not match 
the baud rate of the N30 port. 

Change the maximum speed 
setting of the network connection 
icon to match the speed of the N30 
port. The default N30 port speeds: 
Port 1 - 9600,  
Port 2 and Port 3 - 57,600.  
It may be necessary to attempt 
different speeds to find the correct 
speed. N30 ports can be 
configured only at the speeds 
between 9600 and 57,600. 

When attempting to upload or 
download an N30 with Project 
Builder, you receive an RAS 
680 error code. 

No dial tone. Can be caused by: 
• The phone line is not plugged 

into the modem. 
• The wrong modem is selected 

in the network connection 
icon. 

• You are attempting Direct 
Serial communications and 
the connection type for the 
site in the Site Book is set to 
Modem (Dial-Up) when it 
should be set to Direct Serial 
connection. 

Make sure that the phone line is 
plugged into the modem. 
Make sure the correct modem is 
selected in the network connection 
icon for the site with which you 
want to communicate: 
• Open Dial-up Networking. 
• Right-click the network 

connection icon and select 
Properties. The Connect 
Using field should display the 
name of the modem you are 
using. 

Make sure that the correct 
connection type is specified in the 
Site Book: 
• Open Site Book. 
• Highlight the name of the site 

with which you are attempting 
to communicate. 

• Make sure the Connection 
Attribute is correct. 
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Troubleshooting an N30 Network 
Please see Troubleshooting in the N30 Supervisory Controller 
Networking Technical Bulletin (LIT-6891300). 
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